summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/backup.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-07-23 10:23:40 +0200
committermakefu <github@syntax-fehler.de>2017-07-23 10:23:40 +0200
commit3ee48434e3282ccd2b6ad83dd6c0d6552a54b71d (patch)
tree6c9c0cc04db334cbff93e97fd2f4b0702fdfd1b4 /krebs/2configs/backup.nix
parent20d5077ba6f67ea0b73345248f048eafda6548e4 (diff)
parent54a594dc474255b24bbff80bb6be28e6a1a523d4 (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'krebs/2configs/backup.nix')
-rw-r--r--krebs/2configs/backup.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/krebs/2configs/backup.nix b/krebs/2configs/backup.nix
new file mode 100644
index 000000000..7ee438784
--- /dev/null
+++ b/krebs/2configs/backup.nix
@@ -0,0 +1,21 @@
+{ config, lib, ... }:
+with import <stockholm/lib>;
+{
+ krebs.backup.plans = {
+ } // mapAttrs (_: recursiveUpdate {
+ snapshots = {
+ daily = { format = "%Y-%m-%d"; retain = 7; };
+ weekly = { format = "%YW%W"; retain = 4; };
+ monthly = { format = "%Y-%m"; retain = 12; };
+ yearly = { format = "%Y"; };
+ };
+ }) {
+ wolf-share-puyak = {
+ method = "pull";
+ src = { host = config.krebs.hosts.wolf; path = "/home/share"; };
+ dst = { host = config.krebs.hosts.puyak; path = "/bku/wolf-share"; };
+ startAt = "03:00";
+ };
+ };
+}
+