summaryrefslogtreecommitdiffstats
path: root/jeschli/krops.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-09-08 18:53:49 +0200
committermakefu <github@syntax-fehler.de>2018-09-08 18:53:49 +0200
commite7dd1d0e65b267821811afdb7767669bf79be301 (patch)
tree05bd4d080c203b57cfcdeb3609ddfba96c7369e2 /jeschli/krops.nix
parent7d8825a33ec80b396c1aa3bed5b420ac2ea9abdc (diff)
parent8639e4008a34e5e7d68202a621ef8c95fe3087f4 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'jeschli/krops.nix')
-rw-r--r--jeschli/krops.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/jeschli/krops.nix b/jeschli/krops.nix
new file mode 100644
index 000000000..e55f207d3
--- /dev/null
+++ b/jeschli/krops.nix
@@ -0,0 +1,40 @@
+{ name }: let
+ inherit (import ../krebs/krops.nix { inherit name; })
+ krebs-source
+ lib
+ pkgs
+ ;
+
+ source = { test }: lib.evalSource [
+ krebs-source
+ {
+ nixos-config.symlink = "stockholm/jeschli/1systems/${name}/config.nix";
+ secrets = if test then {
+ file = toString ./2configs/tests/dummy-secrets;
+ } else {
+ pass = {
+ dir = "${lib.getEnv "HOME"}/.password-store";
+ name = "hosts/${name}";
+ };
+ };
+ }
+ ];
+
+in {
+ # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A deploy)
+ deploy = pkgs.krops.writeDeploy "${name}-deploy" {
+ source = source { test = false; };
+ target = "root@${name}/var/src";
+ };
+
+ # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A test)
+ test = pkgs.krops.writeTest "${name}-test" {
+ source = source { test = true; };
+ target = "${lib.getEnv "HOME"}/tmp/${name}-stockholm-test";
+ };
+
+ ci = pkgs.krops.writeTest "${name}-test" {
+ source = source { test = true; };
+ target = "${lib.getEnv "HOME"}/stockholm-build";
+ };
+}