diff options
author | makefu <github@syntax-fehler.de> | 2018-09-10 17:32:31 +0200 |
---|---|---|
committer | makefu <github@syntax-fehler.de> | 2018-09-10 17:32:31 +0200 |
commit | 859f98583788a9324be0e8c52d36a6bb812273fe (patch) | |
tree | 81e1ce4bd2a4185221761165023434f8737fff06 /ci.nix | |
parent | b2a3bd38ea70307c8b136eba42de7cc882afd441 (diff) | |
parent | f6e69c6ecb25fc96655ec1749747d9ccb7880365 (diff) |
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'ci.nix')
-rw-r--r-- | ci.nix | 21 |
1 files changed, 21 insertions, 0 deletions
@@ -0,0 +1,21 @@ +# usage: nix-instantiate --eval --strict --json ./ci.nix +with import ./lib; +let + pkgs = import <nixpkgs> { overlays = [ (import ./submodules/nix-writers/pkgs) ]; }; + system = + import <nixpkgs/nixos/lib/eval-config.nix> { + modules = [{ + imports = [ + ./krebs + ./krebs/2configs + ]; + }]; + } + ; + + ci-systems = filterAttrs (_: v: v.ci) system.config.krebs.hosts; + + build = host: owner: + ((import (toString ./. + "/${owner}/krops.nix") { name = host; }).test {target = "${getEnv "HOME"}/stockholm-build";}); + +in mapAttrs (n: h: build n h.owner.name) ci-systems |