summaryrefslogtreecommitdiffstats
path: root/Zpkgs/krebs/hashPassword.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-24 23:57:12 +0200
committermakefu <github@syntax-fehler.de>2015-07-24 23:57:12 +0200
commitf338d3d4d15ff29b3048b4f89716a8aa1a19f21b (patch)
treebb803bdcc4d93141e16e94e417c69ca8b1b3c9f5 /Zpkgs/krebs/hashPassword.nix
parenta4d2509918c3ce1400071eb0ef2b5421023976ca (diff)
parent99527e88aec089b4fea496248cf03f738bfed257 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'Zpkgs/krebs/hashPassword.nix')
-rw-r--r--Zpkgs/krebs/hashPassword.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/Zpkgs/krebs/hashPassword.nix b/Zpkgs/krebs/hashPassword.nix
new file mode 100644
index 000000000..a10340cc4
--- /dev/null
+++ b/Zpkgs/krebs/hashPassword.nix
@@ -0,0 +1,16 @@
+{ lib, pkgs, ... }:
+
+pkgs.writeScriptBin "hashPassword" ''
+ #! /bin/sh
+ # usage: hashPassword
+ set -euf
+
+ export PATH=${lib.makeSearchPath "bin" (with pkgs; [
+ coreutils
+ mkpasswd
+ openssl
+ ])}
+
+ salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
+ exec mkpasswd -m sha-512 -S "$salt"
+''