summaryrefslogtreecommitdiffstats
path: root/keyboards/cannonkeys/gentoo
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/cannonkeys/gentoo')
-rw-r--r--keyboards/cannonkeys/gentoo/config.h12
-rw-r--r--keyboards/cannonkeys/gentoo/info.json6
-rw-r--r--keyboards/cannonkeys/gentoo/rules.mk6
3 files changed, 6 insertions, 18 deletions
diff --git a/keyboards/cannonkeys/gentoo/config.h b/keyboards/cannonkeys/gentoo/config.h
index 543ac8d550..14b14879d6 100644
--- a/keyboards/cannonkeys/gentoo/config.h
+++ b/keyboards/cannonkeys/gentoo/config.h
@@ -17,22 +17,10 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#pragma once
-/* key matrix size */
-#define MATRIX_ROWS 5
-#define MATRIX_COLS 15
-
#define MATRIX_COL_PINS { C13, C15, B13, B12, B11, B10, B2, B1, B0, A7, A6, A5, A4, A3, A2 }
#define MATRIX_ROW_PINS { C14, A1, B14, B15, A8 }
#define DIODE_DIRECTION COL2ROW
-#define LED_CAPS_LOCK_PIN B3
-#define LED_PIN_ON_STATE 0
-/* define if matrix has ghost */
-//#define MATRIX_HAS_GHOST
-
-/* Set 0 if debouncing isn't needed */
-#define DEBOUNCE 5
-
/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
#define LOCKING_SUPPORT_ENABLE
/* Locking resynchronize hack */
diff --git a/keyboards/cannonkeys/gentoo/info.json b/keyboards/cannonkeys/gentoo/info.json
index 357554d9fc..6b0c9399be 100644
--- a/keyboards/cannonkeys/gentoo/info.json
+++ b/keyboards/cannonkeys/gentoo/info.json
@@ -8,6 +8,12 @@
"pid": "0x000F",
"device_version": "0.0.1"
},
+ "indicators": {
+ "caps_lock": "B3",
+ "on_state": 0
+ },
+ "processor": "STM32F072",
+ "bootloader": "stm32-dfu",
"layouts": {
"LAYOUT_all": {
"layout": [
diff --git a/keyboards/cannonkeys/gentoo/rules.mk b/keyboards/cannonkeys/gentoo/rules.mk
index 7b44b402d1..f56120695a 100644
--- a/keyboards/cannonkeys/gentoo/rules.mk
+++ b/keyboards/cannonkeys/gentoo/rules.mk
@@ -1,9 +1,3 @@
-# MCU name
-MCU = STM32F072
-
-# Bootloader selection
-BOOTLOADER = stm32-dfu
-
# Wildcard to allow APM32 MCU
DFU_SUFFIX_ARGS = -v FFFF -p FFFF