summaryrefslogtreecommitdiffstats
path: root/keyboards/aurora65
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/aurora65')
-rw-r--r--keyboards/aurora65/aurora65.c16
-rw-r--r--keyboards/aurora65/aurora65.h34
-rw-r--r--keyboards/aurora65/config.h92
-rw-r--r--keyboards/aurora65/halconf.h21
-rw-r--r--keyboards/aurora65/keymaps/default/readme.md5
-rw-r--r--keyboards/aurora65/keymaps/via/readme.md5
-rw-r--r--keyboards/aurora65/keymaps/via/rules.mk1
-rw-r--r--keyboards/aurora65/mcuconf.h25
-rw-r--r--keyboards/aurora65/readme.md32
-rw-r--r--keyboards/aurora65/rules.mk29
10 files changed, 0 insertions, 260 deletions
diff --git a/keyboards/aurora65/aurora65.c b/keyboards/aurora65/aurora65.c
deleted file mode 100644
index 0c51c51c5f..0000000000
--- a/keyboards/aurora65/aurora65.c
+++ /dev/null
@@ -1,16 +0,0 @@
-/* Copyright 2022 Yiancar-Designs
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-#include "aurora65.h"
diff --git a/keyboards/aurora65/aurora65.h b/keyboards/aurora65/aurora65.h
deleted file mode 100644
index 5a8f0d6ef4..0000000000
--- a/keyboards/aurora65/aurora65.h
+++ /dev/null
@@ -1,34 +0,0 @@
-/* Copyright 2022 Yiancar-Designs
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-#pragma once
-
-#define XXX KC_NO
-
-#include "quantum.h"
-
-#define LAYOUT_65_ansi_blocker( \
- K00, K01, K02, K03, K04, K05, K06, K07, K08, K09, K0A, K0B, K0C, K0D, K0E, \
- K10, K11, K12, K13, K14, K15, K16, K17, K18, K19, K1A, K1B, K1C, K2C, K1E, \
- K20, K21, K22, K23, K24, K25, K26, K27, K28, K29, K2A, K2B, K2D, K2E, \
- K30, K32, K33, K34, K35, K36, K37, K38, K39, K3A, K3B, K3C, K3D, K3E, \
- K40, K41, K42, K46, K49, K4B, K4C, K4D, K4E \
-) { \
- { K00, K01, K02, K03, K04, K05, K06, K07, K08, K09, K0A, K0B, K0C, K0D, K0E }, \
- { K10, K11, K12, K13, K14, K15, K16, K17, K18, K19, K1A, K1B, K1C, XXX, K1E }, \
- { K20, K21, K22, K23, K24, K25, K26, K27, K28, K29, K2A, K2B, K2C, K2D, K2E }, \
- { K30, XXX, K32, K33, K34, K35, K36, K37, K38, K39, K3A, K3B, K3C, K3D, K3E }, \
- { K40, K41, K42, XXX, XXX, XXX, K46, XXX, XXX, K49, XXX, K4B, K4C, K4D, K4E } \
-}
diff --git a/keyboards/aurora65/config.h b/keyboards/aurora65/config.h
deleted file mode 100644
index d3679d1365..0000000000
--- a/keyboards/aurora65/config.h
+++ /dev/null
@@ -1,92 +0,0 @@
-/*
-Copyright 2022 Yiancar-Designs
-
-This program is free software: you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published byß
-the Free Software Foundation, either version 2 of the License, or
-(at your option) any later version.
-
-This program is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-#pragma once
-
-#include "config_common.h"
-
-/* key matrix size */
-#define MATRIX_ROWS 5
-#define MATRIX_COLS 15
-
-#define MATRIX_ROW_PINS { B3, B4, B5, A8, A4 }
-#define MATRIX_COL_PINS { A13, A10, A9, A14, A15, B8, B9, B2, B1, B0, A0, A1, A2, A3, A5 }
-
-/* COL2ROW, ROW2COL*/
-#define DIODE_DIRECTION COL2ROW
-
-/* Debounce reduces chatter (unintended double-presses) - set 0 if debouncing is not needed */
-#define DEBOUNCE 5
-
-/* RGB Light */
-#define WS2812_PWM_DRIVER PWMD1
-#define WS2812_PWM_CHANNEL 3
-#define WS2812_PWM_PAL_MODE 2
-#define WS2812_PWM_COMPLEMENTARY_OUTPUT
-#define WS2812_DMA_STREAM STM32_DMA1_STREAM5
-#define WS2812_DMA_CHANNEL 5
-#define WS2812_BYTE_ORDER WS2812_BYTE_ORDER_RGB
-
-#define RGB_DI_PIN B15
-#define RGBLED_NUM 36
-#define RGBLIGHT_HUE_STEP 8
-#define RGBLIGHT_SAT_STEP 8
-#define RGBLIGHT_VAL_STEP 8
-#define RGBLIGHT_LIMIT_VAL 255 /* The maximum brightness level */
-#define RGBLIGHT_EFFECT_BREATHING
-#define RGBLIGHT_EFFECT_RAINBOW_MOOD
-#define RGBLIGHT_EFFECT_RAINBOW_SWIRL
-#define RGBLIGHT_EFFECT_SNAKE
-#define RGBLIGHT_EFFECT_KNIGHT
-#define RGBLIGHT_EFFECT_CHRISTMAS
-#define RGBLIGHT_EFFECT_STATIC_GRADIENT
-#define RGBLIGHT_EFFECT_RGB_TEST
-#define RGBLIGHT_EFFECT_ALTERNATING
-#define RGBLIGHT_EFFECT_TWINKLE
-
-/* define if matrix has ghost (lacks anti-ghosting diodes) */
-//#define MATRIX_HAS_GHOST
-
-/* If defined, GRAVE_ESC will always act as ESC when CTRL is held.
- * This is userful for the Windows task manager shortcut (ctrl+shift+esc).
- */
-// #define GRAVE_ESC_CTRL_OVERRIDE
-
-/*
- * Force NKRO
- *
- * Force NKRO (nKey Rollover) to be enabled by default, regardless of the saved
- * state in the bootmagic EEPROM settings. (Note that NKRO must be enabled in the
- * makefile for this to work.)
- *
- * If forced on, NKRO can be disabled via magic key (default = LShift+RShift+N)
- * until the next keyboard reset.
- *
- * NKRO may prevent your keystrokes from being detected in the BIOS, but it is
- * fully operational during normal computer usage.
- *
- * For a less heavy-handed approach, enable NKRO via magic key (LShift+RShift+N)
- * or via bootmagic (hold SPACE+N while plugging in the keyboard). Once set by
- * bootmagic, NKRO mode will always be enabled until it is toggled again during a
- * power-up.
- *
- */
-//#define FORCE_NKRO
-
-/* Bootmagic Lite key configuration */
-#define BOOTMAGIC_LITE_ROW 0
-#define BOOTMAGIC_LITE_COLUMN 0
diff --git a/keyboards/aurora65/halconf.h b/keyboards/aurora65/halconf.h
deleted file mode 100644
index 4abd83bd3b..0000000000
--- a/keyboards/aurora65/halconf.h
+++ /dev/null
@@ -1,21 +0,0 @@
-/* Copyright 2022 Yiancar-Designs
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#pragma once
-
-#define HAL_USE_PWM TRUE
-
-#include_next <halconf.h>
diff --git a/keyboards/aurora65/keymaps/default/readme.md b/keyboards/aurora65/keymaps/default/readme.md
deleted file mode 100644
index 7f9c1461ec..0000000000
--- a/keyboards/aurora65/keymaps/default/readme.md
+++ /dev/null
@@ -1,5 +0,0 @@
-# The default keymap for Aurora65. VIA support disabled.
-
-![Layer 0](https://imgur.com/GZONtj5.png)
-
-![Layer 1](https://imgur.com/C1kFlWX.png)
diff --git a/keyboards/aurora65/keymaps/via/readme.md b/keyboards/aurora65/keymaps/via/readme.md
deleted file mode 100644
index b4b3158e79..0000000000
--- a/keyboards/aurora65/keymaps/via/readme.md
+++ /dev/null
@@ -1,5 +0,0 @@
-# The default keymap for Aurora65. VIA support enabled.
-
-![Layer 0](https://imgur.com/GZONtj5.png)
-
-![Layer 1](https://imgur.com/C1kFlWX.png)
diff --git a/keyboards/aurora65/keymaps/via/rules.mk b/keyboards/aurora65/keymaps/via/rules.mk
deleted file mode 100644
index 1e5b99807c..0000000000
--- a/keyboards/aurora65/keymaps/via/rules.mk
+++ /dev/null
@@ -1 +0,0 @@
-VIA_ENABLE = yes
diff --git a/keyboards/aurora65/mcuconf.h b/keyboards/aurora65/mcuconf.h
deleted file mode 100644
index 5e966ec140..0000000000
--- a/keyboards/aurora65/mcuconf.h
+++ /dev/null
@@ -1,25 +0,0 @@
-/* Copyright 2022 Yiancar-Designs
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#pragma once
-
-#include_next <mcuconf.h>
-
-#undef STM32_PWM_USE_TIM1
-#define STM32_PWM_USE_TIM1 TRUE
-
-#undef STM32_PWM_USE_ADVANCED
-#define STM32_PWM_USE_ADVANCED TRUE
diff --git a/keyboards/aurora65/readme.md b/keyboards/aurora65/readme.md
deleted file mode 100644
index cf0f26330a..0000000000
--- a/keyboards/aurora65/readme.md
+++ /dev/null
@@ -1,32 +0,0 @@
-# Aurora65
-
-This is a 65% layout PCB. It supports VIA.
-
-* Keyboard Maintainer: [Yiancar](http://yiancar-designs.com/) and on [GitHub](https://github.com/yiancar)
-* Hardware Supported: A TKL keyboard with STM32F072CB
-* Hardware Availability: https://www.odinpc.com
-
-## Instructions
-
-### Build
-
-Make example for this keyboard (after setting up your build environment):
-
- make aurora65:default
-
-See the [build environment setup](https://docs.qmk.fm/#/getting_started_build_tools) and the [make instructions](https://docs.qmk.fm/#/getting_started_make_guide) for more information. Brand new to QMK? Start with our [Complete Newbs Guide](https://docs.qmk.fm/#/newbs).
-
-### Reset
-
-- Unplug
-- Hold Escape
-- Plug In
-- Unplug
-- Release Escape
-
-### Flash
-
-- Unplug
-- Hold Escape
-- Plug In
-- Flash using QMK Toolbox or CLI (`make aurora65:<keymap>:flash`)
diff --git a/keyboards/aurora65/rules.mk b/keyboards/aurora65/rules.mk
deleted file mode 100644
index fc545388a3..0000000000
--- a/keyboards/aurora65/rules.mk
+++ /dev/null
@@ -1,29 +0,0 @@
-# MCU name
-MCU = STM32F072
-
-# Bootloader selection
-BOOTLOADER = stm32-dfu
-
-# Wildcard to allow APM32 MCU
-DFU_SUFFIX_ARGS = -v FFFF -p FFFF
-
-# Do not put the microcontroller into power saving mode
-# when we get USB suspend event. We want it to keep updating
-# backlight effects.
-OPT_DEFS += -DCORTEX_ENABLE_WFI_IDLE=TRUE
-
-# Build Options
-# change yes to no to disable
-#
-BOOTMAGIC_ENABLE = yes # Enable Bootmagic Lite
-MOUSEKEY_ENABLE = yes # Mouse keys
-EXTRAKEY_ENABLE = yes # Audio control and System control
-CONSOLE_ENABLE = no # Console for debug
-COMMAND_ENABLE = no # Commands for debug and configuration
-NKRO_ENABLE = yes # Enable N-Key Rollover
-BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
-RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
-WS2812_DRIVER = pwm # Driver for RGB uderglow
-AUDIO_ENABLE = no # Audio output
-
-LAYOUTS = 65_ansi_blocker