From 0f9512d699b3eed35fe23d1f95085f84fbf5c0b9 Mon Sep 17 00:00:00 2001
From: tv <tv@krebsco.de>
Date: Mon, 3 Jul 2023 14:05:12 +0200
Subject: move example configuration to subdirectory

---
 example/config.nix | 48 ++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)
 create mode 100644 example/config.nix

(limited to 'example/config.nix')

diff --git a/example/config.nix b/example/config.nix
new file mode 100644
index 0000000..5e57f59
--- /dev/null
+++ b/example/config.nix
@@ -0,0 +1,48 @@
+{ modulesPath, ... }: {
+	imports = [
+		(modulesPath + "/profiles/qemu-guest.nix")
+	];
+
+  boot.loader.systemd-boot.enable = true;
+  boot.loader.efi.canTouchEfiVariables = true;
+
+  networking.hostName = throw "insert yout hostname here";
+
+  boot.kernelParams = [
+    "console=ttyS0"
+    "console=tty1"
+    "nvme.shutdown_timeout=10"
+    "libiscsi.debug_libiscsi_eh=1"
+    "net.ifnames=0"
+  ];
+
+  boot.initrd.kernelModules = [
+    "nvme"
+  ];
+  boot.kernelModules = [
+    "kvm-amd"
+  ];
+  
+  networking.useDHCP = false;
+  networking.interfaces.eth0.useDHCP = true;
+
+  fileSystems."/" = {
+    device = "/dev/disk/by-label/root";
+    fsType = "ext4";
+  };
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-label/boot";
+    fsType = "vfat";
+  };
+  swapDevices = [{
+    device = "/dev/disk/by-label/swap";
+  }];
+
+  services.openssh.enable = true;
+
+  users.users.root.openssh.authorizedKeys.keys = [
+    (throw "insert your ssh key here")
+  ];
+
+  system.stateVersion = "23.05";
+}
-- 
cgit v1.2.3