summaryrefslogtreecommitdiffstats
path: root/config.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-07-03 14:05:12 +0200
committertv <tv@krebsco.de>2023-07-03 14:05:12 +0200
commit0f9512d699b3eed35fe23d1f95085f84fbf5c0b9 (patch)
tree532b3a252569a7ff263d3ac939f4464079804051 /config.nix
parent83fba08b6edfaea68c6b6571391eaf045c57d3f3 (diff)
move example configuration to subdirectory
Diffstat (limited to 'config.nix')
-rw-r--r--config.nix48
1 files changed, 0 insertions, 48 deletions
diff --git a/config.nix b/config.nix
deleted file mode 100644
index 5e57f59..0000000
--- a/config.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-{ modulesPath, ... }: {
- imports = [
- (modulesPath + "/profiles/qemu-guest.nix")
- ];
-
- boot.loader.systemd-boot.enable = true;
- boot.loader.efi.canTouchEfiVariables = true;
-
- networking.hostName = throw "insert yout hostname here";
-
- boot.kernelParams = [
- "console=ttyS0"
- "console=tty1"
- "nvme.shutdown_timeout=10"
- "libiscsi.debug_libiscsi_eh=1"
- "net.ifnames=0"
- ];
-
- boot.initrd.kernelModules = [
- "nvme"
- ];
- boot.kernelModules = [
- "kvm-amd"
- ];
-
- networking.useDHCP = false;
- networking.interfaces.eth0.useDHCP = true;
-
- fileSystems."/" = {
- device = "/dev/disk/by-label/root";
- fsType = "ext4";
- };
- fileSystems."/boot" = {
- device = "/dev/disk/by-label/boot";
- fsType = "vfat";
- };
- swapDevices = [{
- device = "/dev/disk/by-label/swap";
- }];
-
- services.openssh.enable = true;
-
- users.users.root.openssh.authorizedKeys.keys = [
- (throw "insert your ssh key here")
- ];
-
- system.stateVersion = "23.05";
-}