aboutsummaryrefslogtreecommitdiffstats
path: root/pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
index 9238d32..df32f59 100644
--- a/pkgs/default.nix
+++ b/pkgs/default.nix
@@ -125,12 +125,11 @@ pkgs: oldpkgs: {
inherit text;
passAsFile = [ "text" ];
} /* sh */ ''
- PATH=${makeBinPath (with pkgs; [
- # TODO remove if everyone migrated to 18.03
- (if hasAttr "binutils-unwrapped" pkgs then binutils-unwrapped else binutils)
- coreutils
- gcc
- ])}
+ PATH=${makeBinPath [
+ pkgs.binutils-unwrapped
+ pkgs.coreutils
+ pkgs.gcc
+ ]}
exe=$out${destination}
mkdir -p "$(dirname "$exe")"
gcc -O -Wall -o "$exe" -x c "$textPath"