aboutsummaryrefslogtreecommitdiffstats
path: root/pkgs/default.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-10-27 16:39:12 +0200
committerjeschli <jeschli@gmail.com>2018-10-27 16:39:12 +0200
commit566830bb18e1ca74dad4152b9d156bc9c02e70e7 (patch)
tree05ee938dba84cd0ec94896e2803659d6aba6e2b0 /pkgs/default.nix
parentf6b2139310546574942a1319cadab973b616d888 (diff)
writeDash: documentation
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
index 4cc0df3..2ffd414 100644
--- a/pkgs/default.nix
+++ b/pkgs/default.nix
@@ -219,6 +219,12 @@ pkgs: oldpkgs: {
strip --strip-unneeded "$exe"
'';
+ # Like writeScript but the first line is a shebang to dash
+ #
+ # Example:
+ # writeDash "example" ''
+ # echo hello world
+ # ''
writeDash = pkgs.makeScriptWriter {
interpreter = "${pkgs.dash}/bin/dash";
};