aboutsummaryrefslogtreecommitdiffstats
path: root/examples/hello_world.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-09-12 14:57:09 +0200
committerlassulus <lassulus@lassul.us>2018-09-16 16:47:24 +0200
commit9cd634f650551080b01e06763c11836ce33e0613 (patch)
treec9e3b55ab4fbd3aa8a8811967f500b9025fd7ad4 /examples/hello_world.nix
parent368a04fec30837037079d13c3704b9766af37eb8 (diff)
pkgs: add writePerl{,Bin}
Diffstat (limited to 'examples/hello_world.nix')
-rw-r--r--examples/hello_world.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/hello_world.nix b/examples/hello_world.nix
index 4bb3db1..4944c13 100644
--- a/examples/hello_world.nix
+++ b/examples/hello_world.nix
@@ -18,6 +18,9 @@ in {
main = do
putStrLn "hello world"
'';
+ perl = pkgs.writePerl "hello-world" {} ''
+ print "hello world\n";
+ '';
python2 = pkgs.writePython2 "hello-world" {} ''
print "hello world"
'';