aboutsummaryrefslogtreecommitdiffstats
path: root/examples/hello_world.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-09-23 13:05:11 +0200
committerlassulus <lassulus@lassul.us>2018-09-23 13:11:50 +0200
commit79ab2c27f9d7903ff3ed9bcd8de493b1191bbc12 (patch)
tree0a6fa22ad13a1597bd0d796bc74a388f3da6d0c5 /examples/hello_world.nix
parent3212b4fbfb6fff4a1f133b9e18b84f298c6da65d (diff)
pkgs: add writeJS{,Bin}v2.2.0lass/masterlass/ciderp2
Diffstat (limited to 'examples/hello_world.nix')
-rw-r--r--examples/hello_world.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/hello_world.nix b/examples/hello_world.nix
index 4944c13..4f9330a 100644
--- a/examples/hello_world.nix
+++ b/examples/hello_world.nix
@@ -18,6 +18,9 @@ in {
main = do
putStrLn "hello world"
'';
+ js = pkgs.writeJS "hello-world" {} ''
+ console.log("hello world")
+ '';
perl = pkgs.writePerl "hello-world" {} ''
print "hello world\n";
'';