summaryrefslogtreecommitdiffstats
path: root/nix/mime-mail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/mime-mail.nix')
-rw-r--r--nix/mime-mail.nix26
1 files changed, 11 insertions, 15 deletions
diff --git a/nix/mime-mail.nix b/nix/mime-mail.nix
index 96c097e..e855038 100644
--- a/nix/mime-mail.nix
+++ b/nix/mime-mail.nix
@@ -1,10 +1,8 @@
-# This file was auto-generated by cabal2nix. Please do NOT edit manually!
-
-{ cabal, base64Bytestring, blazeBuilder, fetchgit, filepath, hspec
-, random, sendmail ? "sendmail", text
+{ mkDerivation, base, base64-bytestring, blaze-builder, bytestring
+, fetchgit, filepath, hspec, process, random, sendmail ? "sendmail"
+, stdenv, text
}:
-
-cabal.mkDerivation (self: {
+mkDerivation {
pname = "mime-mail";
version = "0.4.6.2";
src = fetchgit {
@@ -13,14 +11,12 @@ cabal.mkDerivation (self: {
rev = "3d0f060fb4c58b69c72ce3b4911bff32df7329a7";
};
buildDepends = [
- base64Bytestring blazeBuilder filepath random text
+ base base64-bytestring blaze-builder bytestring filepath process
+ random text
];
- testDepends = [ blazeBuilder hspec text ];
+ testDepends = [ base blaze-builder bytestring hspec text ];
configureFlags = "--ghc-option=-DMIME_MAIL_SENDMAIL_PATH=\"${sendmail}\"";
- meta = {
- homepage = "http://github.com/snoyberg/mime-mail";
- description = "Compose MIME email messages";
- license = self.stdenv.lib.licenses.mit;
- platforms = self.ghc.meta.platforms;
- };
-})
+ homepage = "http://github.com/snoyberg/mime-mail";
+ description = "Compose MIME email messages";
+ license = stdenv.lib.licenses.mit;
+}