summaryrefslogtreecommitdiffstats
path: root/src/usb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/usb/Makefile.am')
-rw-r--r--src/usb/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/usb/Makefile.am b/src/usb/Makefile.am
new file mode 100644
index 00000000..bca39bfe
--- /dev/null
+++ b/src/usb/Makefile.am
@@ -0,0 +1,21 @@
+# This is _NOT_ the library release version, it's an API version.
+# Please read chapter "Library interface versions" of the libtool documentation
+# before making any modifications: https://www.gnu.org/software/libtool/manual/html_node/Versioning.html
+LIBVERSION=0:0:0
+
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)/include
+AM_CFLAGS = -fPIC -Wall $(LIBUSB_CFLAGS) $(TALLOC_CFLAGS)
+AM_LDFLAGS = $(COVERAGE_LDFLAGS)
+
+if ENABLE_LIBUSB
+
+lib_LTLIBRARIES = libosmousb.la
+
+libosmousb_la_SOURCES = osmo_libusb.c
+libosmosim_la_LDFLAGS = -version-info $(LIBVERSION)
+libosmosim_la_LIBADD = \
+ $(top_builddir)/src/libosmocore.la \
+ $(TALLOC_LIBS) \
+ $(LIBUSB_LIBS)
+
+endif