summaryrefslogtreecommitdiffstats
path: root/src/ctrl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/ctrl/Makefile.am')
-rw-r--r--src/ctrl/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/ctrl/Makefile.am b/src/ctrl/Makefile.am
index 8bf34429..1817caca 100644
--- a/src/ctrl/Makefile.am
+++ b/src/ctrl/Makefile.am
@@ -5,6 +5,7 @@ LIBVERSION=0:0:0
AM_CFLAGS = -Wall $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)/include $(TALLOC_CFLAGS)
+if ENABLE_CTRL
lib_LTLIBRARIES = libosmoctrl.la
libosmoctrl_la_SOURCES = control_cmd.c control_if.c
@@ -18,3 +19,5 @@ libosmoctrl_la_LIBADD = \
if ENABLE_VTY
libosmoctrl_la_SOURCES += control_vty.c
endif
+
+endif