summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 00000000..b2877148
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,15 @@
+if BUILD_MAN
+man_MANS = osmo-config-merge.8
+endif
+
+ASCIIDOCS = osmo-config-merge.adoc
+
+A2X_OPTS_MANPAGE = --doctype manpage --format manpage -D ${builddir}
+
+%.8 : %.adoc
+ a2x ${A2X_OPTS_MANPAGE} $<
+
+EXTRA_DIST = ${ASCIIDOCS}
+
+CLEANFILES = \
+ osmo-config-merge.8