summaryrefslogtreecommitdiffstats
path: root/include/osmocom/core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/osmocom/core/Makefile.am')
-rw-r--r--include/osmocom/core/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/osmocom/core/Makefile.am b/include/osmocom/core/Makefile.am
index f131269d..aabb775f 100644
--- a/include/osmocom/core/Makefile.am
+++ b/include/osmocom/core/Makefile.am
@@ -3,7 +3,8 @@ osmocore_HEADERS = signal.h linuxlist.h timer.h select.h msgb.h bits.h \
gsmtap.h write_queue.h prim.h \
logging.h rate_ctr.h gsmtap_util.h \
crc16.h panic.h process.h \
- backtrace.h conv.h application.h
+ backtrace.h conv.h application.h \
+ crcgen.h crc8gen.h crc16gen.h crc32gen.h crc64gen.h
if ENABLE_PLUGIN
osmocore_HEADERS += plugin.h
@@ -22,3 +23,7 @@ osmocore_HEADERS += serial.h
endif
osmocoredir = $(includedir)/osmocom/core
+
+crc%gen.h: crcXXgen.h.tpl
+ @echo " SED $< -> $@"
+ @sed -e's/XX/$*/g' $< > $@