summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 126e9a56..74c266e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,9 +89,9 @@ AC_ARG_ENABLE([pcsc], [AS_HELP_STRING([--disable-pcsc], [Build without PC/SC sup
[
enable_pcsc="yes"
])
-if test "x$enable_pcsc" = "xyes" ; then
+AS_IF([test "x$enable_pcsc" = "xyes"], [
PKG_CHECK_MODULES(PCSC, libpcsclite)
-fi
+])
AM_CONDITIONAL(ENABLE_PCSC, test "x$enable_pcsc" = "xyes")
AC_ARG_ENABLE(talloc,
@@ -109,12 +109,12 @@ AC_ARG_ENABLE(system-talloc,
)],
[enable_system_talloc=$enableval], [enable_system_talloc="no"])
AM_CONDITIONAL(ENABLE_SYSTEM_TALLOC, [test x"$enable_system_talloc" = x"yes"])
-if test x"$enable_system_talloc" = x"yes"; then
+AS_IF([test x"$enable_system_talloc" = x"yes"], [
PKG_CHECK_MODULES(TALLOC, talloc)
if test x"$enable_talloc" = x"yes"; then
AC_MSG_ERROR([You cannot enable both internal and system talloc])
fi
-fi
+])
AC_ARG_ENABLE(plugin,
[AS_HELP_STRING(