summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bc3358a0..4a00e695 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,10 @@ AC_SUBST(LIBRARY_DLSYM)
AC_CHECK_LIB(execinfo, backtrace, BACKTRACE_LIB=-lexecinfo, BACKTRACE_LIB=)
AC_SUBST(BACKTRACE_LIB)
+# check for old glibc < 2.17 to get clock_gettime
+AC_SEARCH_LIBS([clock_gettime], [rt posix4], [LIBRARY_RT="$LIBS";LIBS=""])
+AC_SUBST(LIBRARY_RT)
+
AC_ARG_ENABLE(doxygen,
[AS_HELP_STRING(
[--disable-doxygen],