summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7fc72fda..80e2bccb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,16 @@ CHECK_TM_INCLUDES_TM_GMTOFF
dnl Generate the output
AC_CONFIG_HEADER(config.h)
+AC_ARG_ENABLE([pcsc], [AS_HELP_STRING([--disable-pcsc], [Build without PC/SC support])],
+ [
+ osmo_ac_have_pcsc=$enableval
+ ],
+ [
+ PKG_CHECK_MODULES(PCSC, libpcsclite)
+ osmo_ac_have_pcsc="yes"
+ ])
+AM_CONDITIONAL(ENABLE_PCSC, test "x$osmo_ac_have_pcsc" = "xyes")
+
AC_ARG_ENABLE(talloc,
[AS_HELP_STRING(
[--disable-talloc],