summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a18197d7..672a6dff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,6 +226,22 @@ then
CPPFLAGS+=" -fsanitize=address -fsanitize=undefined"
fi
+AC_ARG_ENABLE(simd,
+ [AS_HELP_STRING(
+ [--disable-simd],
+ [Disable SIMD support]
+ )],
+ [simd=$enableval], [simd="yes"])
+if test x"$simd" = x"yes"
+then
+ # Find and define supported SIMD extensions
+ AX_CHECK_SIMD
+else
+ AM_CONDITIONAL(HAVE_AVX2, false)
+ AM_CONDITIONAL(HAVE_SSE3, false)
+ AM_CONDITIONAL(HAVE_SSE4_1, false)
+fi
+
AC_OUTPUT(
libosmocore.pc
libosmocodec.pc