summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f6df9bb..b8de3cad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,11 +19,14 @@ if HAVE_DOXYGEN
html_DATA = $(top_builddir)/doc/html.tar
+doc: $(html_DATA)
+
$(html_DATA): $(top_builddir)/doc/core/html/index.html \
$(top_builddir)/doc/gsm/html/index.html \
$(top_builddir)/doc/vty/html/index.html \
$(top_builddir)/doc/codec/html/index.html \
- $(top_builddir)/doc/coding/html/index.html
+ $(top_builddir)/doc/coding/html/index.html \
+ $(top_builddir)/doc/gb/html/index.html
cd $(top_builddir)/doc && tar cf html.tar */html
$(top_builddir)/doc/core/html/index.html: $(SOURCES) Doxyfile.core
@@ -50,13 +53,18 @@ $(top_builddir)/doc/coding/html/index.html: Doxyfile.coding
mkdir -p doc/coding
$(DOXYGEN) Doxyfile.coding
+$(top_builddir)/doc/gb/html/index.html: $(SOURCES) Doxyfile.gb
+ @rm -rf doc/gb
+ mkdir -p doc/gb
+ $(DOXYGEN) Doxyfile.gb
+
install-data-hook:
cd $(DESTDIR)$(htmldir) && tar xf html.tar && rm -f html.tar
uninstall-hook:
- cd $(DESTDIR)$(htmldir) && rm -rf {core,gsm,vty,codec,coding}
+ cd $(DESTDIR)$(htmldir) && rm -rf {core,gsm,vty,codec,coding,gb}
-DX_CLEAN = doc/{core,gsm,vty,codec,coding}/html/search/* doc/{core,gsm,vty,codec,coding}/{html,latex}/* doc/html.tar doc/{core,gsm,vty,codec,coding}/doxygen_sqlite3.db doc/*.tag
+DX_CLEAN = doc/{core,gsm,vty,codec,coding,gb}/html/search/* doc/{core,gsm,vty,codec,coding,gb}/{html,latex}/* doc/html.tar doc/{core,gsm,vty,codec,coding,gb}/doxygen_sqlite3.db doc/*.tag
endif
MOSTLYCLEANFILES = $(DX_CLEAN)