summaryrefslogtreecommitdiffstats
path: root/tests/oap/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-07-30 18:14:45 +0200
committerHarald Welte <laforge@gnumonks.org>2018-07-30 18:24:49 +0200
commit6db529aedd61191e1d574f97d62bebc8bcaf057d (patch)
treea4515b4d9f9ee36c15d3c8e45f2526b396a3b5e7 /tests/oap/Makefile.am
parent9b04c17c7a450fa83282f133283a86f4a0c2fd6f (diff)
import oap_client_test from osmo-sgsn
As oap_client has moved from osmo-sgsn to libosmogsm, it is only fair that the related unit test shall also be moved here. Change-Id: I9d64e10b4bacac9b530cf077841bad762fc6d558
Diffstat (limited to 'tests/oap/Makefile.am')
-rw-r--r--tests/oap/Makefile.am37
1 files changed, 0 insertions, 37 deletions
diff --git a/tests/oap/Makefile.am b/tests/oap/Makefile.am
deleted file mode 100644
index 06ccf338..00000000
--- a/tests/oap/Makefile.am
+++ /dev/null
@@ -1,37 +0,0 @@
-AM_CPPFLAGS = \
- $(all_includes) \
- -I$(top_srcdir)/include \
- $(NULL)
-
-AM_CFLAGS = \
- -Wall \
- -ggdb3 \
- $(LIBOSMOCORE_CFLAGS) \
- $(LIBOSMOGSM_CFLAGS) \
- $(NULL)
-
-EXTRA_DIST = \
- oap_test.ok \
- $(NULL)
-
-if HAVE_LIBGTP
-if HAVE_LIBCARES
-noinst_PROGRAMS = \
- oap_test \
- $(NULL)
-endif
-endif
-
-oap_test_SOURCES = \
- oap_test.c \
- $(NULL)
-
-oap_test_LDADD = \
- $(top_builddir)/src/gprs/oap.o \
- $(top_builddir)/src/gprs/oap_messages.o \
- $(top_builddir)/src/gprs/gprs_utils.o \
- $(top_builddir)/src/libcommon/libcommon.a \
- $(LIBOSMOCORE_LIBS) \
- $(LIBOSMOGSM_LIBS) \
- -lrt
-