summaryrefslogtreecommitdiffstats
path: root/tests/conv/Makefile.am
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2011-11-24 17:48:42 +0100
committerSylvain Munaut <tnt@246tNt.com>2011-11-24 17:48:42 +0100
commit29eb92db02afed5ba060ac861bcffe7e61915f71 (patch)
treea0efc494bcbee06a9902a0fcd2dc69207076992b /tests/conv/Makefile.am
parentae8dbb4d776461c8945570594d67d8bb9b7100c5 (diff)
core/conv: Add regression testing code
It tests both a given test vector encoding/decoding, and some random coding/decoding cycles. Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'tests/conv/Makefile.am')
-rw-r--r--tests/conv/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/conv/Makefile.am b/tests/conv/Makefile.am
new file mode 100644
index 00000000..75cfec8d
--- /dev/null
+++ b/tests/conv/Makefile.am
@@ -0,0 +1,6 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+noinst_PROGRAMS = conv_test
+EXTRA_DIST = conv_test.ok
+
+conv_test_SOURCES = conv_test.c
+conv_test_LDADD = $(top_builddir)/src/libosmocore.la