summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-05-15 16:39:56 +0200
committerHarald Welte <laforge@gnumonks.org>2017-05-17 15:15:09 +0100
commita362ee90b42898dc730ffddf3bdc1b7a6523f1b8 (patch)
treef898daebc184cae1a65a490332afad36d7dd4662 /tests/Makefile.am
parent7af6d22a4e15ea7dde5869ca6784e06dbff87a28 (diff)
add sercomm unit test
Change-Id: I9e2e7fcda28e7c6844d5faa09e02acf537cea44d
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d95083b0..97af698c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -16,7 +16,7 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
tlv/tlv_test gsup/gsup_test oap/oap_test fsm/fsm_test \
write_queue/wqueue_test socket/socket_test \
coding/coding_test conv/conv_gsm0503_test \
- abis/abis_test endian/endian_test
+ abis/abis_test endian/endian_test sercomm/sercomm_test
if ENABLE_MSGFILE
check_PROGRAMS += msgfile/msgfile_test
@@ -165,6 +165,9 @@ coding_coding_test_LDADD = \
endian_endian_test_SOURCES = endian/endian_test.c
endian_endian_test_LDADD = $(top_builddir)/src/libosmocore.la
+sercomm_sercomm_test_SOURCES = sercomm/sercomm_test.c
+sercomm_sercomm_test_LDADD = $(top_builddir)/src/libosmocore.la
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \
@@ -207,7 +210,8 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
osmo-auc-gen/osmo-auc-gen_test.sh \
osmo-auc-gen/osmo-auc-gen_test.ok \
osmo-auc-gen/osmo-auc-gen_test.err \
- conv/conv_gsm0503_test.ok endian/endian_test.ok
+ conv/conv_gsm0503_test.ok endian/endian_test.ok \
+ sercomm/sercomm_test.ok
DISTCLEANFILES = atconfig atlocal conv/gsm0503_test_vectors.c
BUILT_SOURCES = conv/gsm0503_test_vectors.c