summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2017-10-18 13:14:49 +0200
committerMax <msuraev@sysmocom.de>2017-10-24 08:21:59 +0000
commit9818664315a514b187719792d77723ad9e18dcdf (patch)
tree2bfdaef10f7437fa81634440d125ab3ec446637c /tests/Makefile.am
parentea66852a62319901dc198ea1dc8cbfbf77217347 (diff)
Add tests for bitvec_write_field()
This function is actively used by OsmoPCU but have not been covered by tests so far. The test code is based on Minh-Quang Nguyen <minh-quang.nguyen@nutaq.com> submission with some modifications. The test's FIXME will be addressed in follow-up patches. Change-Id: I2ee544256b8675bc62a42493aab66a8eeee54f90 Related: OS#1526
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index dbe349f5..7fb9a7bd 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -11,6 +11,7 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
loggingrb/loggingrb_test strrb/strrb_test \
comp128/comp128_test smscb/gsm0341_test \
bitvec/bitvec_test msgb/msgb_test bits/bitcomp_test \
+ bits/bitfield_test \
tlv/tlv_test gsup/gsup_test oap/oap_test fsm/fsm_test \
write_queue/wqueue_test socket/socket_test \
coding/coding_test conv/conv_gsm0503_test \
@@ -77,6 +78,9 @@ bitvec_bitvec_test_LDADD = $(top_builddir)/src/libosmocore.la
bits_bitcomp_test_SOURCES = bits/bitcomp_test.c
bits_bitcomp_test_LDADD = $(top_builddir)/src/libosmocore.la
+bits_bitfield_test_SOURCES = bits/bitfield_test.c
+bits_bitfield_test_LDADD = $(top_builddir)/src/libosmocore.la
+
conv_conv_test_SOURCES = conv/conv_test.c conv/conv.c
conv_conv_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libgsmint.la
@@ -232,7 +236,7 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
vty/ok_more_spaces.cfg \
vty/ok_tabs_and_spaces.cfg \
vty/ok_tabs.cfg \
- comp128/comp128_test.ok \
+ comp128/comp128_test.ok bits/bitfield_test.ok \
utils/utils_test.ok stats/stats_test.ok \
bitvec/bitvec_test.ok msgb/msgb_test.ok bits/bitcomp_test.ok \
sim/sim_test.ok tlv/tlv_test.ok abis/abis_test.ok \