summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2017-01-19 03:33:24 +0700
committerHarald Welte <laforge@gnumonks.org>2017-03-06 17:06:45 +0000
commit68930e85b5945db8ffea055fd178bc1f88b31d99 (patch)
tree9f8dc6855539d156c6a49e9c8b5a425fcaf2355e /tests/Makefile.am
parent77a5b0946f67d0228a4dbb5a04940070e12ebf2f (diff)
tests/conv: separate test logic
To be able to add some more tests, related to convolutional coding, without duplication of code, the test logic was separated from the conv_test.c into conv.c and conv.h. Change-Id: Idbdc7e19cb9b9a36cd1fccd621cd858e87530d98
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 35b91501..0472082e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -57,7 +57,7 @@ bitvec_bitvec_test_LDADD = $(top_builddir)/src/libosmocore.la
bits_bitcomp_test_SOURCES = bits/bitcomp_test.c
bits_bitcomp_test_LDADD = $(top_builddir)/src/libosmocore.la
-conv_conv_test_SOURCES = conv/conv_test.c
+conv_conv_test_SOURCES = conv/conv_test.c conv/conv.c
conv_conv_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libgsmint.la
gsm0808_gsm0808_test_SOURCES = gsm0808/gsm0808_test.c
@@ -187,6 +187,7 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
socket/socket_test.err
DISTCLEANFILES = atconfig atlocal
+noinst_HEADERS = conv/conv.h
TESTSUITE = $(srcdir)/testsuite