summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2016-03-14 21:04:50 +0100
committerHarald Welte <laforge@gnumonks.org>2016-03-17 16:55:11 +0100
commit676e53446285d1b8f514580fd9485d1f27493c0b (patch)
tree1faea4123fd528d5581397ef80c3403af45f3ea7 /tests/Makefile.am
parent4acaa13433cc15e4f1d9ee850d78af47419768ab (diff)
sim: Add simplistic unit test for APDU class tables
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 571e87b0..03506af3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -12,7 +12,8 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
loggingrb/loggingrb_test strrb/strrb_test \
vty/vty_test comp128/comp128_test utils/utils_test \
smscb/gsm0341_test stats/stats_test \
- bitvec/bitvec_test msgb/msgb_test bits/bitcomp_test
+ bitvec/bitvec_test msgb/msgb_test bits/bitcomp_test \
+ sim/sim_test
if ENABLE_MSGFILE
check_PROGRAMS += msgfile/msgfile_test
@@ -105,6 +106,8 @@ strrb_strrb_test_LDADD = $(top_builddir)/src/libosmocore.la
vty_vty_test_SOURCES = vty/vty_test.c
vty_vty_test_LDADD = $(top_builddir)/src/vty/libosmovty.la $(top_builddir)/src/libosmocore.la
+sim_sim_test_SOURCES = sim/sim_test.c
+sim_sim_test_LDADD = $(top_builddir)/src/sim/libosmosim.la $(top_builddir)/src/libosmocore.la
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
@@ -139,7 +142,8 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
loggingrb/logging_test.err strrb/strrb_test.ok \
vty/vty_test.ok comp128/comp128_test.ok \
utils/utils_test.ok stats/stats_test.ok \
- bitvec/bitvec_test.ok msgb/msgb_test.ok bits/bitcomp_test.ok
+ bitvec/bitvec_test.ok msgb/msgb_test.ok bits/bitcomp_test.ok \
+ sim/sim_test.ok
DISTCLEANFILES = atconfig