summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMax <max.suraev@fairwaves.ru>2013-12-02 11:30:32 +0100
committerHarald Welte <laforge@gnumonks.org>2013-12-07 18:10:38 +0100
commit4f0abc0e3eb553c94e8e409ea14a1b047efe3028 (patch)
treead3ce264e1640fc0bfa732e08f2f733d4ba76f73 /tests/Makefile.am
parent56cc60dc2079a63e983d746689fd03d9a48ea8f5 (diff)
Refactor COMP128v23 implementation and add test suit
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1bb26cef..98ede3b8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -7,7 +7,7 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
gb/bssgp_fc_test gb/gprs_ns_test \
logging/logging_test fr/fr_test \
loggingrb/loggingrb_test strrb/strrb_test \
- vty/vty_test
+ vty/vty_test comp128/comp128_test
if ENABLE_MSGFILE
check_PROGRAMS += msgfile/msgfile_test
@@ -16,6 +16,9 @@ endif
a5_a5_test_SOURCES = a5/a5_test.c
a5_a5_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libosmogsm.la
+comp128_comp128_test_SOURCES = comp128/comp128_test.c
+comp128_comp128_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libosmogsm.la
+
auth_milenage_test_SOURCES = auth/milenage_test.c
auth_milenage_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libosmogsm.la
@@ -101,7 +104,7 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
logging/logging_test.ok logging/logging_test.err \
fr/fr_test.ok loggingrb/logging_test.ok \
loggingrb/logging_test.err strrb/strrb_test.ok \
- vty/vty_test.ok
+ vty/vty_test.ok comp128/comp128_test.ok
DISTCLEANFILES = atconfig