summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2017-01-19 17:01:15 +0700
committerVadim Yanitskiy <axilirator@gmail.com>2017-04-30 02:59:42 +0700
commit33e03065a508f1238056f36841b97d38083ac18b (patch)
tree70d51d4763293829835b53d71dca1113920f788a /tests/Makefile.am
parentf74cfd35acadbebe7ccd9fc02d05920958f43ad3 (diff)
tests/conv: add GSM 05.03 specific test
This change extends the convolutional code test coverage, adding the GSM 05.03 specific test vectors, generated by the conv_gen.py. Inspired by Tom's patch: http://lists.osmocom.org/pipermail/openbsc/2014-April/007364.html Change-Id: I76d1cd4032d2f74c5bb93bde4fab99aa655b7f1a
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3ce76208..d9816ef4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -15,7 +15,8 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
bitvec/bitvec_test msgb/msgb_test bits/bitcomp_test \
tlv/tlv_test gsup/gsup_test oap/oap_test fsm/fsm_test \
write_queue/wqueue_test socket/socket_test \
- coding/coding_test abis/abis_test
+ coding/coding_test conv/conv_gsm0503_test \
+ abis/abis_test
if ENABLE_MSGFILE
check_PROGRAMS += msgfile/msgfile_test
@@ -64,6 +65,10 @@ bits_bitcomp_test_LDADD = $(top_builddir)/src/libosmocore.la
conv_conv_test_SOURCES = conv/conv_test.c conv/conv.c
conv_conv_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libgsmint.la
+conv_conv_gsm0503_test_SOURCES = conv/conv_gsm0503_test.c conv/conv.c conv/gsm0503_test_vectors.c
+conv_conv_gsm0503_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libgsmint.la
+conv_conv_gsm0503_test_CPPFLAGS = $(AM_CPPFLAGS) -I$(top_srcdir)/tests/conv
+
gsm0808_gsm0808_test_SOURCES = gsm0808/gsm0808_test.c
gsm0808_gsm0808_test_LDADD = $(top_builddir)/src/libosmocore.la $(top_builddir)/src/gsm/libosmogsm.la
@@ -198,9 +203,11 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
socket/socket_test.err coding/coding_test.ok \
osmo-auc-gen/osmo-auc-gen_test.sh \
osmo-auc-gen/osmo-auc-gen_test.ok \
- osmo-auc-gen/osmo-auc-gen_test.err
+ osmo-auc-gen/osmo-auc-gen_test.err \
+ conv/conv_gsm0503_test.ok
-DISTCLEANFILES = atconfig atlocal
+DISTCLEANFILES = atconfig atlocal conv/gsm0503_test_vectors.c
+BUILT_SOURCES = conv/gsm0503_test_vectors.c
noinst_HEADERS = conv/conv.h
TESTSUITE = $(srcdir)/testsuite
@@ -221,3 +228,7 @@ AUTOTEST = $(AUTOM4TE) --language=autotest
$(TESTSUITE): $(srcdir)/testsuite.at $(srcdir)/package.m4
$(AUTOTEST) -I '$(srcdir)' -o $@.tmp $@.at
mv $@.tmp $@
+
+conv/gsm0503_test_vectors.c: $(top_srcdir)/utils/conv_gen.py $(top_srcdir)/utils/conv_codes_gsm.py
+ $(AM_V_GEN)python2 $(top_srcdir)/utils/conv_gen.py gen_vectors gsm \
+ --target-path $(builddir)/conv