summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-05-15 12:07:51 +0200
committerHarald Welte <laforge@gnumonks.org>2017-05-15 13:42:00 +0200
commit3318c657dea52c143842dab0e0f7733288f7bd4d (patch)
treeef025d5907529f7d4f4614e6d110e54b9ca0e045 /tests/Makefile.am
parent054667fe15434e7e467311c7213b50f849aecc79 (diff)
introduce byteswap.h with osmo_{htonl,ntohl,htons,ntohs}
We need to have an architecture-independend way of endian conversion / byte swapping functions which will also work on embedded (bare iron) builds. Let's introduce osmocom/core/bytesawp.h for this purpose. Change-Id: Ibc0cc1e36d4ed63a35cf8ceff3af0f26e5ac7a3d
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d9816ef4..d95083b0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -16,7 +16,7 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
tlv/tlv_test gsup/gsup_test oap/oap_test fsm/fsm_test \
write_queue/wqueue_test socket/socket_test \
coding/coding_test conv/conv_gsm0503_test \
- abis/abis_test
+ abis/abis_test endian/endian_test
if ENABLE_MSGFILE
check_PROGRAMS += msgfile/msgfile_test
@@ -162,6 +162,9 @@ coding_coding_test_LDADD = \
$(top_builddir)/src/codec/libosmocodec.la \
$(top_builddir)/src/coding/libosmocoding.la
+endian_endian_test_SOURCES = endian/endian_test.c
+endian_endian_test_LDADD = $(top_builddir)/src/libosmocore.la
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \
@@ -204,7 +207,7 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
osmo-auc-gen/osmo-auc-gen_test.sh \
osmo-auc-gen/osmo-auc-gen_test.ok \
osmo-auc-gen/osmo-auc-gen_test.err \
- conv/conv_gsm0503_test.ok
+ conv/conv_gsm0503_test.ok endian/endian_test.ok
DISTCLEANFILES = atconfig atlocal conv/gsm0503_test_vectors.c
BUILT_SOURCES = conv/gsm0503_test_vectors.c