summaryrefslogtreecommitdiffstats
path: root/src/vty/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2017-09-23 19:30:07 +0330
committerVadim Yanitskiy <axilirator@gmail.com>2017-09-27 11:02:19 +0000
commit463deef8c209dd7eb023ac70bf41fa9893ad35ed (patch)
tree2a5a73c3fa0ada0feca863029a0d8294bdc8839c /src/vty/Makefile.am
parent5584a14a319044f75c9d8ea74abb6dede21ea721 (diff)
VTY: implement talloc context introspection command
This change introduces a new command, which could be used to inspect the application's talloc context directly from VTY. To enable this feature, an application need to provide it's context via the 'vty_app_info' struct, and register the VTY command by calling the osmo_talloc_vty_add_cmds(). The new command is a sub-command of 'show': show talloc-context <context> <depth> [filter] Currently the following contexts may be inspected: - application - a context provided by an application; - null - all contexts, if NULL-context tracking is enabled. A report depth is defined by the next parameter, and could be: - full - full tree report, as the talloc_report_full() does; - brief - brief tree report, as the talloc_report() does; - DEPTH - user defined maximal report depth. Also, there are two optional report filters: - regexp - print only contexts, matching a regular expression; - tree - print a specific context, pointed by specified address. The command output is formatted the same way as in case of calling the talloc_report() or talloc_report_full(). Change-Id: I43fc42880b22294d83c565ae600ac65e4f38b30d
Diffstat (limited to 'src/vty/Makefile.am')
-rw-r--r--src/vty/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/vty/Makefile.am b/src/vty/Makefile.am
index e083a1ce..1dc76c34 100644
--- a/src/vty/Makefile.am
+++ b/src/vty/Makefile.am
@@ -10,7 +10,8 @@ if ENABLE_VTY
lib_LTLIBRARIES = libosmovty.la
libosmovty_la_SOURCES = buffer.c command.c vty.c vector.c utils.c \
- telnet_interface.c logging_vty.c stats_vty.c fsm_vty.c
+ telnet_interface.c logging_vty.c stats_vty.c \
+ fsm_vty.c talloc_ctx_vty.c
libosmovty_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined $(TALLOC_LIBS)
libosmovty_la_LIBADD = $(top_builddir)/src/libosmocore.la
endif