summaryrefslogtreecommitdiffstats
path: root/src/vty/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-05-19 19:02:52 +0200
committerHarald Welte <laforge@gnumonks.org>2010-05-25 22:28:39 +0200
commit3fb0b6f26e24370490f1051e2c795ba8fa6ac892 (patch)
tree1f3b86f491e7f0812f5424daaffd4db9cf8ac452 /src/vty/Makefile.am
parent75bd69bc914d4ecd1b19f65662889af173aca64c (diff)
Create libosmovty as library from OpenBSC VTY functions
Diffstat (limited to 'src/vty/Makefile.am')
-rw-r--r--src/vty/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/vty/Makefile.am b/src/vty/Makefile.am
new file mode 100644
index 00000000..bc10a0f8
--- /dev/null
+++ b/src/vty/Makefile.am
@@ -0,0 +1,11 @@
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
+LIBVERSION=0:0:0
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS = -fPIC -Wall
+
+lib_LTLIBRARIES = libosmovty.la
+
+libosmovty_la_SOURCES = buffer.c command.c vty.c vector.c utils.c \
+ telnet_interface.c logging_vty.c