summaryrefslogtreecommitdiffstats
path: root/src/sim/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2014-10-26 20:14:04 +0100
committerHarald Welte <laforge@gnumonks.org>2014-10-26 20:14:04 +0100
commita97ebc9599d4b3210d7127a2cc75d552e69eeb9a (patch)
tree60eee24f5b78ad5115b21cb9996406e5cbf4fd3d /src/sim/Makefile.am
parent42645d7d78a22db7b76039407b7b43bc0cc79c54 (diff)
parent534163badec879a644af985c9f5d04b7c957a355 (diff)
Merge branch 'laforge/sim'
This contains some work from 2012 about creating a general library about the data structure of data contained on SIM cards. This 'libosmosim' is supposed to be used by (among others) * tools to review/modify/personalize SIM card filesystem data * virtual SIM card implementation
Diffstat (limited to 'src/sim/Makefile.am')
-rw-r--r--src/sim/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/sim/Makefile.am b/src/sim/Makefile.am
new file mode 100644
index 00000000..2b30ae99
--- /dev/null
+++ b/src/sim/Makefile.am
@@ -0,0 +1,21 @@
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
+LIBVERSION=0:0:0
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS = -fPIC -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(PCSC_CFLAGS)
+AM_LDFLAGS = $(COVERAGE_LDFLAGS)
+
+if ENABLE_PCSC
+# FIXME: only build the PC/SC dependent part conditional, but always build other parts
+
+noinst_HEADERS = sim_int.h gsm_int.h
+
+lib_LTLIBRARIES = libosmosim.la
+
+libosmosim_la_SOURCES = core.c reader.c reader_pcsc.c \
+ card_fs_sim.c card_fs_usim.c card_fs_uicc.c card_fs_isim.c card_fs_tetra.c
+libosmosim_la_LDFLAGS = -version-info $(LIBVERSION)
+libosmosim_la_LIBADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(PCSC_LIBS)
+
+endif