summaryrefslogtreecommitdiffstats
path: root/src/pseudotalloc/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-05-15 21:37:34 +0200
committerHarald Welte <laforge@gnumonks.org>2017-05-17 15:15:52 +0100
commit898ffefde4198a23a92810a9cf39ff6846f3bb39 (patch)
treeab4f79425d35ade4b542b0b6d57b58992408321f /src/pseudotalloc/Makefile.am
parent7f24c155f5acd898cd49f9f429500461fa4fd8a5 (diff)
add libpseudotalloc as super-simplistic talloc replacement
In tightly embedded builds (--enable-embedded), we want the ability to replace talloc with a very simple heap allocator to avoid the complexity of talloc without modifying all our code that assumes talloc. This will break the hierarchical notion of the allocator, but libosmo{core,gsm,coding,codec} don't rely on that anyway. Change-Id: Ie341034076f242a813f081919dd09d845775ad35
Diffstat (limited to 'src/pseudotalloc/Makefile.am')
-rw-r--r--src/pseudotalloc/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/pseudotalloc/Makefile.am b/src/pseudotalloc/Makefile.am
new file mode 100644
index 00000000..3c78bba8
--- /dev/null
+++ b/src/pseudotalloc/Makefile.am
@@ -0,0 +1,12 @@
+AM_CFLAGS = -Wall -I. $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)/include
+
+if ENABLE_PSEUDOTALLOC
+
+lib_LTLIBRARIES = libpseudotalloc.la
+
+libpseudotalloc_la_SOURCES = pseudotalloc.c
+libpseudotalloc_la_LDFLAGS = -no-undefined
+
+nobase_include_HEADERS = talloc.h
+
+endif