summaryrefslogtreecommitdiffstats
path: root/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2017-10-26 10:56:04 +0200
committerHarald Welte <laforge@gnumonks.org>2017-11-02 18:06:26 +0000
commited029dfab959bca74bd43d86922727c2047eeb4d (patch)
tree07ed1e7bff8b0f154e949b62ffc1b0ba60098e4f /src/gsm/Makefile.am
parent69b61fe510dd9357040ad0a9f3a1449d913067a7 (diff)
Enable GnuTLS fallback
On systems with GNU/Linux kernel older than 3.17 (Debian 8 "jessie" for example) the osmo_get_rand_id() would always return failure due to missing getrandom() syscall. To support such systems, let's add fallback code which uses GnuTLS library. It can be disabled explicitly via '--disable-gnutls' option at compile-time, otherwise ./configure will fail if both getrandom() and GnuTLS are not available. When building with '--enable-embedded' the fallback is disabled automatically. Related: OS#1694 Change-Id: Ic77866ce65acf524b768882c751a4f9c0635740b
Diffstat (limited to 'src/gsm/Makefile.am')
-rw-r--r--src/gsm/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/gsm/Makefile.am b/src/gsm/Makefile.am
index 44769713..12f56db1 100644
--- a/src/gsm/Makefile.am
+++ b/src/gsm/Makefile.am
@@ -38,6 +38,11 @@ libosmogsm_la_SOURCES =
libosmogsm_la_LDFLAGS = $(LTLDFLAGS_OSMOGSM) -version-info $(LIBVERSION) -no-undefined
libosmogsm_la_LIBADD = libgsmint.la $(TALLOC_LIBS)
+if ENABLE_GNUTLS
+AM_CPPFLAGS += $(LIBGNUTLS_CFLAGS)
+libosmogsm_la_LIBADD += $(LIBGNUTLS_LIBS)
+endif
+
EXTRA_DIST = libosmogsm.map
# Convolutional codes generation