summaryrefslogtreecommitdiffstats
path: root/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2016-04-27 18:32:35 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-12-11 03:42:58 +0100
commitc0f00072929b126b21ba7bdfa2c93327ba652d08 (patch)
tree92442c5f1ab1b533ba27047093e8676b7b5223f3 /src/gsm/Makefile.am
parent9795cf1b126d5567dbd0a25b56e9ba75be9513c1 (diff)
import oap message parsing / encoding from openbsc.git; AGPL->GPL
In the process, also: * Change the license from AGPLv3 to GPLv2-or-later; * correct spelling of 'sysmocom' to lowercase; * add '2016' to the copyright; * rename to osmo_*; * add API docs; * add logging category DLOAP: define id and add to internal_cat; * redirect all oap.c logging to DLOAP. A unit test will follow in a subsequent patch, since it needs a minor tweak for decoding of boolean values. The related openbsc change-id is I2f06aaa6eb54eafa860cfed8e72e41d82ff1c4cf. Tweaked-by: Neels Hofmeyr Change-Id: If5099e60681a215e798b6675f21813f26769c253
Diffstat (limited to 'src/gsm/Makefile.am')
-rw-r--r--src/gsm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gsm/Makefile.am b/src/gsm/Makefile.am
index 3877f78a..4ea55e1d 100644
--- a/src/gsm/Makefile.am
+++ b/src/gsm/Makefile.am
@@ -22,7 +22,7 @@ libgsmint_la_SOURCES = a5.c rxlev_stat.c tlv_parser.c comp128.c comp128v23.c \
auth_milenage.c milenage/aes-encblock.c gea.c \
milenage/aes-internal.c milenage/aes-internal-enc.c \
milenage/milenage.c gan.c ipa.c gsm0341.c apn.c \
- gsup.c gprs_gea.c gsm0503_conv.c
+ gsup.c gprs_gea.c gsm0503_conv.c oap.c
libgsmint_la_LDFLAGS = -no-undefined
libgsmint_la_LIBADD = $(top_builddir)/src/libosmocore.la