summaryrefslogtreecommitdiffstats
path: root/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-10-04 03:15:47 +0200
committerNeels Hofmeyr <neels@hofmeyr.de>2017-10-05 19:44:28 +0200
commit9cd1e7417e76c98094a502131af779145a77c7b9 (patch)
treebe447dced7f7e891271c8f88b3b8b738db4a2357 /src/gsm/Makefile.am
parentee497f245e78929ddb69ba1f06d27bcc886f6597 (diff)
add osmo_imsi_str_valid() and osmo_msisdn_str_valid()
Add GSM23003_IMSI_MIN_DIGITS definition. Add regression test gsm23003_test.c to test the two new functions. Will be used by OsmoHLR to validate VTY and CTRL input. Change-Id: I1e94f5b0717b947d2a7a7d36bacdf04a75cb3522
Diffstat (limited to 'src/gsm/Makefile.am')
-rw-r--r--src/gsm/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/gsm/Makefile.am b/src/gsm/Makefile.am
index 08cd5e65..48b8b2cf 100644
--- a/src/gsm/Makefile.am
+++ b/src/gsm/Makefile.am
@@ -29,7 +29,8 @@ libgsmint_la_SOURCES = a5.c rxlev_stat.c tlv_parser.c comp128.c comp128v23.c \
auth_milenage.c milenage/aes-encblock.c gea.c \
milenage/aes-internal.c milenage/aes-internal-enc.c \
milenage/milenage.c gan.c ipa.c gsm0341.c apn.c \
- gsup.c gprs_gea.c gsm0503_conv.c oap.c gsm0808_utils.c
+ gsup.c gprs_gea.c gsm0503_conv.c oap.c gsm0808_utils.c \
+ gsm23003.c
libgsmint_la_LDFLAGS = -no-undefined
libgsmint_la_LIBADD = $(top_builddir)/src/libosmocore.la