summaryrefslogtreecommitdiffstats
path: root/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2016-04-25 18:46:22 +0200
committerHarald Welte <laforge@gnumonks.org>2016-05-06 11:21:06 +0200
commit3b6fb0880c3ab1e23a3d7d738d073b00c2a794c2 (patch)
tree081531b62c35cbe124e799ab104fe7913cb997f0 /src/gsm/Makefile.am
parent9709b2e6fd84cab48fc7844475518f68f937bb01 (diff)
import gprs_gsup_message.[ch] from openbsc as gsup.[ch]
Move those routines from OpenBSC to libosmogsm, so they can be re-used from other programs. I think it was a mistake to add them only inside the openbsc repository in the first place. We need to pay more attention to this in the future.
Diffstat (limited to 'src/gsm/Makefile.am')
-rw-r--r--src/gsm/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/gsm/Makefile.am b/src/gsm/Makefile.am
index 4326b357..781f153a 100644
--- a/src/gsm/Makefile.am
+++ b/src/gsm/Makefile.am
@@ -26,7 +26,8 @@ libgsmint_la_SOURCES = a5.c rxlev_stat.c tlv_parser.c comp128.c comp128v23.c \
auth_core.c auth_comp128v1.c auth_comp128v23.c \
auth_milenage.c milenage/aes-encblock.c \
milenage/aes-internal.c milenage/aes-internal-enc.c \
- milenage/milenage.c gan.c ipa.c gsm0341.c apn.c
+ milenage/milenage.c gan.c ipa.c gsm0341.c apn.c \
+ gsup.c
libgsmint_la_LDFLAGS = -no-undefined
libgsmint_la_LIBADD = ../libosmocore.la