summaryrefslogtreecommitdiffstats
path: root/src/ctrl/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2014-08-20 19:18:15 +0200
committerHarald Welte <laforge@gnumonks.org>2014-08-21 15:34:17 +0200
commitdda42251532c347af66ccd6f515745ab83eb8bd5 (patch)
treece3eda356832fe89284e84685629b5bf6fe9de9e /src/ctrl/Makefile.am
parent5ad742d56e9f0d7d3e442ddde17bba94d6b1e6c4 (diff)
libctr: rename/move control interface to libosmocore naming scheme
Diffstat (limited to 'src/ctrl/Makefile.am')
-rw-r--r--src/ctrl/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/ctrl/Makefile.am b/src/ctrl/Makefile.am
new file mode 100644
index 00000000..4f039c82
--- /dev/null
+++ b/src/ctrl/Makefile.am
@@ -0,0 +1,7 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(LIBOSMOABIS_LIBS) $(COVERAGE_LDFLAGS)
+
+noinst_LIBRARIES = libctrl.a
+
+libctrl_a_SOURCES = control_if.c control_cmd.c