summaryrefslogtreecommitdiffstats
path: root/src/coding/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2016-09-23 01:48:59 +0700
committerVadim Yanitskiy <axilirator@gmail.com>2017-03-07 01:06:38 +0700
commit3262f820b5cfb4c76448f605c9804f3e5ca1023d (patch)
tree1d62b0b5a454955e71e6ce91a869d54f1d8df154 /src/coding/Makefile.am
parent68930e85b5945db8ffea055fd178bc1f88b31d99 (diff)
libosmocoding: migrate transcoding routines from OsmoBTS
There are some projects, such as GR-GSM and OsmocomBB, which would benefit from using one shared implementation of GSM 05.03 code. So, this commit introduces a new sub-library called libosmocoding, which (for now) provides GSM, GPRS and EDGE transcoding routines, migrated from OsmoBTS. The original GSM 05.03 code from OsmoBTS was relicensed under GPLv2-or-later with permission of copyright holders (Andreas Eversberg, Alexander Chemeris and Tom Tsou). The following data types are currently supported: - xCCH - PDTCH (CS 1-4 and MCS 1-9) - TCH/FR - TCH/HR - TCH/AFS - RCH/AHS - RACH - SCH Change-Id: I0c3256b87686d878e4e716d12393cad5924fdfa1
Diffstat (limited to 'src/coding/Makefile.am')
-rw-r--r--src/coding/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/coding/Makefile.am b/src/coding/Makefile.am
new file mode 100644
index 00000000..5a055c8d
--- /dev/null
+++ b/src/coding/Makefile.am
@@ -0,0 +1,27 @@
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool
+# documentation before making any modification
+LIBVERSION = 0:0:0
+
+AM_CPPFLAGS = -I$(top_srcdir)/include $(TALLOC_CFLAGS)
+AM_CFLAGS = -Wall
+
+lib_LTLIBRARIES = libosmocoding.la
+
+libosmocoding_la_SOURCES = \
+ gsm0503_interleaving.c \
+ gsm0503_mapping.c \
+ gsm0503_tables.c \
+ gsm0503_parity.c \
+ gsm0503_coding.c
+libosmocoding_la_LDFLAGS = \
+ -version-info \
+ $(LIBVERSION) \
+ -no-undefined \
+ $(TALLOC_LIBS)
+libosmocoding_la_LIBADD = \
+ ../libosmocore.la \
+ ../gsm/libosmogsm.la \
+ ../codec/libosmocodec.la
+
+EXTRA_DIST = libosmocoding.map