summaryrefslogtreecommitdiffstats
path: root/src/codec/Makefile.am
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2016-05-25 18:13:51 +0200
committerHolger Freyther <holger@freyther.de>2016-05-31 10:11:51 +0000
commit92db150488bdadf6577a4968feabd5a3ab694c5e (patch)
treebbe91ee76c6dd6e41077ba22d29dc9c574b13516 /src/codec/Makefile.am
parentadef12a3497d14aafe677b77b468b952f4c6b5d5 (diff)
Add helper functions for AMR codec
* add functions to encode/decode various codec paramters from RTP payload with AMR frame according to RFC 4867 * those functions are extended version based on code from osmo-bts' amr.c by Andreas Eversberg * add corresponding enum types and strings for logging * add regression tests It's useful both to replace manual parsing in osmo-bts with fuctions covered by test suite and as a debugging helpers for issues related to AMR. Change-Id: Ia217679a07d3fbc970f435e20f6eac33d34bd597 Related: OS#1562 Reviewed-on: https://gerrit.osmocom.org/118 Tested-by: Jenkins Builder Reviewed-by: Holger Freyther <holger@freyther.de>
Diffstat (limited to 'src/codec/Makefile.am')
-rw-r--r--src/codec/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/codec/Makefile.am b/src/codec/Makefile.am
index b4834e52..619897f5 100644
--- a/src/codec/Makefile.am
+++ b/src/codec/Makefile.am
@@ -2,7 +2,7 @@
# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
LIBVERSION=0:0:0
-AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CPPFLAGS = -I$(top_srcdir)/include $(TALLOC_CFLAGS)
AM_CFLAGS = -Wall
lib_LTLIBRARIES = libosmocodec.la