summaryrefslogtreecommitdiffstats
path: root/src/codec/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2019-08-01 20:05:05 +0200
committerlaforge <laforge@gnumonks.org>2019-09-02 09:13:50 +0000
commit750d8311f5c0455f2caaa2ae9dba2cc99300c9dd (patch)
treeaebab66fccee63d0b6da29e23ca3944d0d80c2e9 /src/codec/Makefile.am
parent766f77c3d9b479b49e6e2bc2b105ceb4889304d3 (diff)
codec/ecu: Introduce new generic Error Concealment Unit abstraction
We don't want to expose the details of a given ECU implementation to the user (e.g. osmo-bts), but have a generic abstraction layer where an ECU implementation can simply register a few call-back functions with the generic core. As the developer and copyright holder of the related code, I hereby state that any ECU implementation using 'struct osmo_ecu_ops' and registering with the 'osmo_ecu_register()' function shall not be considered as a derivative work under any applicable copyright law; the copyleft terms of GPLv2 shall hence not apply to any such ECU implementation. The intent of the above exception is to allow anyone to combine third party Error Concealment Unit implementations with libosmocore, including but not limited to such published by ETSI. Change-Id: I4d33c9c7c2d4c7462ff38a49c178b65accae1915
Diffstat (limited to 'src/codec/Makefile.am')
-rw-r--r--src/codec/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/codec/Makefile.am b/src/codec/Makefile.am
index b522d43a..c9d7a228 100644
--- a/src/codec/Makefile.am
+++ b/src/codec/Makefile.am
@@ -13,6 +13,6 @@ endif
lib_LTLIBRARIES = libosmocodec.la
-libosmocodec_la_SOURCES = gsm610.c gsm620.c gsm660.c gsm690.c ecu_fr.c
+libosmocodec_la_SOURCES = gsm610.c gsm620.c gsm660.c gsm690.c ecu.c ecu_fr.c
libosmocodec_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined
libosmocodec_la_LIBADD = $(top_builddir)/src/libosmocore.la