summaryrefslogtreecommitdiffstats
path: root/src/codec/Makefile.am
diff options
context:
space:
mode:
authorPhilipp Maier <pmaier@sysmocom.de>2017-12-16 03:42:15 +0700
committerVadim Yanitskiy <axilirator@gmail.com>2018-01-15 20:12:03 +0000
commit40def49ac4b8babbd1b17c232137ce50a428706b (patch)
treebd7fe78e287a432825f765fa2a42e96fd857de84 /src/codec/Makefile.am
parentc0771d62c19a09608a570a433da5c0c9de6f4884 (diff)
libosmocodec: implement ECU (Error Concealment Unit) for FR
When a bad GSM voice frame is received, it's being replaced by a silence frame. This may cause unpleasant audio effects. This change implements a functionality to craft a replacement frame from the last known good frame. Currently, only FR is supported, support for other codecs may be added latter. Change-Id: I06a21f60db01bfe1c2b838f93866fad1d53fdcd1
Diffstat (limited to 'src/codec/Makefile.am')
-rw-r--r--src/codec/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/codec/Makefile.am b/src/codec/Makefile.am
index b4df5da7..f77d910b 100644
--- a/src/codec/Makefile.am
+++ b/src/codec/Makefile.am
@@ -13,6 +13,6 @@ endif
lib_LTLIBRARIES = libosmocodec.la
-libosmocodec_la_SOURCES = gsm610.c gsm620.c gsm660.c gsm690.c
+libosmocodec_la_SOURCES = gsm610.c gsm620.c gsm660.c gsm690.c ecu_fr.c
libosmocodec_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined
libosmocodec_la_LIBADD = $(top_builddir)/src/libosmocore.la