summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-05-11 17:39:21 +0200
committerHarald Welte <laforge@gnumonks.org>2018-05-11 21:57:46 +0200
commit9da77abb6b7a023f2dcc1564835e89d9436d6793 (patch)
tree716a8cec6d2e2e4b9ce3a57a251e67504d5e5997 /src/Makefile.am
parent85b9fbae7e1a6bcf62597877f4b3a13474fac956 (diff)
isdnhdlc: Port from kernel to userspace
* prefix all symbols/constants with osmo_ * use stdint.h types instead of kernel types * use Doxygen API documentation * use Osmocom CRC16-CCITT functions * use Osmocom bit-reversal functions * integrate with Automake Change-Id: I109085ab3e412c20b19cd42fb7137aa0e4167542
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2a77d5e3..45fb89df 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,7 +22,8 @@ libosmocore_la_SOURCES = timer.c timer_gettimeofday.c timer_clockgettime.c \
conv.c application.c rbtree.c strrb.c \
loggingrb.c crc8gen.c crc16gen.c crc32gen.c crc64gen.c \
macaddr.c stat_item.c stats.c stats_statsd.c prim.c \
- conv_acc.c conv_acc_generic.c sercomm.c prbs.c
+ conv_acc.c conv_acc_generic.c sercomm.c prbs.c \
+ isdnhdlc.c
if HAVE_SSSE3
libosmocore_la_SOURCES += conv_acc_sse.c