summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2013-03-03 10:07:16 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2013-03-03 10:10:07 +0100
commit45cdaa095a0e2fe9558de682e1c12229dfab9adc (patch)
tree493306deac8b645b8af85fba8d5e099aa9467721 /src/Makefile.am
parented8170ac676a0a59df39f9c73ec84996fc222145 (diff)
cygwin: Link many libraries with -no-undefined to create a dll
Only the Gb library relies on having undefined references to a symbol that needs to be provided by the host application. For all other libraries we can link with -no-undefined.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 081be966..e85f3e30 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,9 +18,9 @@ BUILT_SOURCES = crc8gen.c crc16gen.c crc32gen.c crc64gen.c
if ENABLE_PLUGIN
libosmocore_la_SOURCES += plugin.c
-libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) $(LIBRARY_DL)
+libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) $(LIBRARY_DL) -no-undefined
else
-libosmocore_la_LDFLAGS = -version-info $(LIBVERSION)
+libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined
endif
if ENABLE_TALLOC