summaryrefslogtreecommitdiffstats
path: root/openbsc/src/libctrl/Makefile.am
diff options
context:
space:
mode:
authorDaniel Willmann <daniel@totalueberwachung.de>2010-10-21 15:00:36 +0200
committerHarald Welte <laforge@gnumonks.org>2014-08-21 15:34:11 +0200
commit1264cb404f460576690f52fdc8032b74de0bc04e (patch)
tree1e74adefdbb122c3f67bf9727e62bc55c85dcd19 /openbsc/src/libctrl/Makefile.am
parent28570a4e6208e704e8d4feed0081e576d449e4ac (diff)
Add libctrl, an SNMP-like control interface
In contrast to the VTY interface the control interface is meant to be used by programs. This patch adds basic support, no commands are defined.
Diffstat (limited to 'openbsc/src/libctrl/Makefile.am')
-rw-r--r--openbsc/src/libctrl/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/openbsc/src/libctrl/Makefile.am b/openbsc/src/libctrl/Makefile.am
new file mode 100644
index 00000000..286929b8
--- /dev/null
+++ b/openbsc/src/libctrl/Makefile.am
@@ -0,0 +1,7 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(COVERAGE_LDFLAGS)
+
+noinst_LIBRARIES = libctrl.a
+
+libctrl_a_SOURCES = control_if.c control_cmd.c