summaryrefslogtreecommitdiffstats
path: root/include/osmocore/Makefile.am
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2010-07-25 18:08:54 +0200
committerSylvain Munaut <tnt@246tNt.com>2010-07-25 18:08:54 +0200
commitac3e61a7a6b8f56b74d4ebd9c0fcb9c5935294b1 (patch)
tree894fd9150a39bb1442467bdb1867b07d2b475cfe /include/osmocore/Makefile.am
parentf23ababfb2160f3189c19898c1ae5a987be1ba47 (diff)
core: Add some generic panic handling
This also includes an option for a minimal 'infinite loop' type panic that could be required for embedded target that don't have abort() or fprintf() Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'include/osmocore/Makefile.am')
-rw-r--r--include/osmocore/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/osmocore/Makefile.am b/include/osmocore/Makefile.am
index 8334f148..ecdc65c9 100644
--- a/include/osmocore/Makefile.am
+++ b/include/osmocore/Makefile.am
@@ -2,7 +2,7 @@ osmocore_HEADERS = signal.h linuxlist.h timer.h select.h msgb.h \
tlv.h bitvec.h comp128.h statistics.h gsm_utils.h utils.h \
gsmtap.h write_queue.h rsl.h gsm48.h rxlev_stat.h mncc.h \
gsm48_ie.h logging.h gsm0808.h rate_ctr.h gsmtap_util.h \
- plugin.h crc16.h
+ plugin.h crc16.h panic.h
if ENABLE_TALLOC
osmocore_HEADERS += talloc.h