summaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2018-07-02 20:28:55 +0700
committerVadim Yanitskiy <axilirator@gmail.com>2018-07-02 20:30:31 +0700
commit94c0031297abb0bb42a4ea23e68f944622f50469 (patch)
tree5e2382f50bdb9b26ddc27e058c2c3dcd87cc2ab6 /include/Makefile.am
parentbc568d0b9f216f8d3c26b888131f4a9a7e9d368d (diff)
Don't enforce Python 2 for utilities
The conv_gen.py utility was tested against both Python 2 and 3, so there is no need to enforce Python 2. Also, having: #!/usr/local/bin/python{2|3} is a bad idea, because Python may be installed in a different location. Change-Id: I6007d481047b584db13d6eda70fb99f11f9ddaa1
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 27a40908..38ba14cd 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -162,7 +162,7 @@ osmocom/core/crc%gen.h: osmocom/core/crcXXgen.h.tpl
$(AM_V_GEN)sed -e's/XX/$*/g' $< > $@
osmocom/gsm/gsm0503.h: $(top_srcdir)/utils/conv_gen.py $(top_srcdir)/utils/conv_codes_gsm.py
- $(AM_V_GEN)python2 $(top_srcdir)/utils/conv_gen.py gen_header gsm \
+ $(AM_V_GEN)python $(top_srcdir)/utils/conv_gen.py gen_header gsm \
--target-path $(builddir)/osmocom/gsm
CLEANFILES = osmocom/gsm/gsm0503.h