summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2016-12-21 11:35:13 +0100
committerHarald Welte <laforge@gnumonks.org>2016-12-22 13:54:32 +0000
commit126def710563e1d4b5f16f354176a2088d17e28c (patch)
tree91f3866c4e29dedef36c65855e88f9e6e6189954 /debian/rules
parent7309e19358240100e56f2d6af8af61a5bb5630da (diff)
Integrate Debian packaging changes
debian/control: * restructure to make it easier to incorporate further changes * update package descriptions * move build-depends to a proper place * update project URL debian/rules: * use proper hardening syntax * strip linker option without explicit shell invocation * remove useless comment * add extra cleanup debian/: package documentation separately debian/docs: remove empty file debian/coryright: update to match Debian format Change-Id: Ia7654d34730e9f269831612bfba70a1338ce29d3 Related: OS#1694
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules35
1 files changed, 26 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 3cce05e9..e1735102 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,4 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -13,10 +7,9 @@ DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
-# Our tests want to override symbols, make it possible on Ubuntu
-export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS | sed -e 's/-Wl,-Bsymbolic-functions//')
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-export DEB_BUILD_HARDENING=1
+export DEB_LDFLAGS_MAINT_STRIP = -Wl,-Bsymbolic-functions
%:
dh $@ --with autoreconf --fail-missing
@@ -38,3 +31,27 @@ override_dh_autoreconf:
override_dh_auto_configure:
dh_auto_configure -- --enable-static
+
+override_dh_clean:
+ dh_clean
+ $(RM) .version
+ $(RM) debian/man/osmo-arfcn.1
+ $(RM) debian/man/osmo-auc-gen.1
+ $(RM) include/osmocom/core/bit16gen.h
+ $(RM) include/osmocom/core/bit32gen.h
+ $(RM) include/osmocom/core/bit64gen.h
+ $(RM) include/osmocom/core/crc16gen.h
+ $(RM) include/osmocom/core/crc32gen.h
+ $(RM) include/osmocom/core/crc64gen.h
+ $(RM) include/osmocom/core/crc8gen.h
+ $(RM) src/crc16gen.c
+ $(RM) src/crc32gen.c
+ $(RM) src/crc64gen.c
+ $(RM) src/crc8gen.c
+ $(RM) tests/package.m4
+ $(RM) tests/testsuite
+ $(RM) -r doc/codec/
+ $(RM) -r doc/core/
+ $(RM) -r doc/gsm/
+ $(RM) -r doc/vty/html/
+ $(RM) -r doc/vty/latex/